[webkit-reviews] review granted: [Bug 95435] [NRWT] Add support for recognizing arbitrary process names in crash lines : [Attachment 161424] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Aug 30 01:33:50 PDT 2012


Adam Barth <abarth at webkit.org> has granted jochen at chromium.org's request for
review:
Bug 95435: [NRWT] Add support for recognizing arbitrary process names in crash
lines
https://bugs.webkit.org/show_bug.cgi?id=95435

Attachment 161424: Patch
https://bugs.webkit.org/attachment.cgi?id=161424&action=review

------- Additional Comments from Adam Barth <abarth at webkit.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=161424&action=review


> Tools/Scripts/webkitpy/layout_tests/port/driver.py:313
> +	       m = re.match('#(?:CRASHED|PROCESS UNRESPONSIVE) - (\S+)',
error_line)

Can we use a variable name that's more descriptive than "m" ?

> Tools/Scripts/webkitpy/layout_tests/port/driver.py:317
> +	       if m:
> +		   self._crashed_process_name = m.group(1)
> +	       else:
> +		   self._crashed_process_name = 'WebProcess'

This really wants to be a ternary expression.


More information about the webkit-reviews mailing list