[webkit-reviews] review denied: [Bug 93210] CSSParser: Move enumeration to a common place (StylePropertyShorthand) : [Attachment 159704] Following the suggestion about naming the function

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Aug 22 16:13:22 PDT 2012


Dean Jackson <dino at apple.com> has denied Adenilson Cavalcanti Silva
<savagobr at yahoo.com>'s request for review:
Bug 93210: CSSParser: Move enumeration to a common place
(StylePropertyShorthand)
https://bugs.webkit.org/show_bug.cgi?id=93210

Attachment 159704: Following the suggestion about naming the function
https://bugs.webkit.org/attachment.cgi?id=159704&action=review

------- Additional Comments from Dean Jackson <dino at apple.com>
View in context: https://bugs.webkit.org/attachment.cgi?id=159704&action=review


I wonder if webkitAnimationShorthandForParsing() is a better name? It makes it
clear why we have this (annoying) duplication. I don't have a strong opinion
either way.

Otherwise, just some small fixes needed before r+.

> Source/WebCore/css/CSSParser.cpp:3064
> +    const WebCore::StylePropertyShorthand& animationProperties =
WebCore::webkitAnimationShorthandNameLast();

Why do you need the WebCore:: here?

> Source/WebCore/css/CSSParser.cpp:3071
> +    ASSERT(numProperties == webkitAnimationShorthandNameLast().length());
> +    ASSERT(webkitAnimationShorthand().length() ==
webkitAnimationShorthandNameLast().length());

You could compare to the animationProperties local variable.

> Source/WebCore/css/StylePropertyShorthand.cpp:275
> +    static const CSSPropertyID animationPropertiesLast[] = {

Why not animationPropertiesNameLast to be consistent?


More information about the webkit-reviews mailing list