[webkit-reviews] review denied: [Bug 94356] [chromium/mac] Respect system setting for rubber-banding. : [Attachment 159478] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Aug 20 17:50:47 PDT 2012


Beth Dakin <bdakin at apple.com> has denied asvitkine at chromium.org's request for
review:
Bug 94356: [chromium/mac] Respect system setting for rubber-banding.
https://bugs.webkit.org/show_bug.cgi?id=94356

Attachment 159478: Patch
https://bugs.webkit.org/attachment.cgi?id=159478&action=review

------- Additional Comments from Beth Dakin <bdakin at apple.com>
View in context: https://bugs.webkit.org/attachment.cgi?id=159478&action=review


I think this patch is close, but I would like to see the things I commented on
cleaned up.

> Source/WebCore/platform/mac/ScrollAnimatorMac.mm:651
> +	   NSString* key = @"NSScrollViewRubberbanding";

For Objective-C objects, our style guide dictates that the * should go next to
the variable name, not the type name. In other words, this should be: NSString
*key…

> Source/WebCore/platform/mac/ScrollAnimatorMac.mm:652
> +	   NSUserDefaults* defaults = [NSUserDefaults standardUserDefaults];

Same as above.

> Source/WebCore/platform/mac/ScrollAnimatorMac.mm:654
> +	   id value = [defaults objectForKey:key];

Can you just use boolForKey here instead of objectForKey? And then avoid all of
the conversions below?


More information about the webkit-reviews mailing list