[webkit-reviews] review denied: [Bug 88973] Web Inspector: [WebGL] Add minimum transport protocol from backend to frontend : [Attachment 159385] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Aug 20 06:51:59 PDT 2012


Pavel Feldman <pfeldman at chromium.org> has denied Andrey Adaikin
<aandrey at chromium.org>'s request for review:
Bug 88973: Web Inspector: [WebGL] Add minimum transport protocol from backend
to frontend
https://bugs.webkit.org/show_bug.cgi?id=88973

Attachment 159385: Patch
https://bugs.webkit.org/attachment.cgi?id=159385&action=review

------- Additional Comments from Pavel Feldman <pfeldman at chromium.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=159385&action=review


> Source/WebCore/inspector/InjectedScriptWebGLModule.cpp:75
> +void InjectedScriptWebGLModule::captureFrame(ErrorString* errorString,
String* traceLogId)

captureTraceLog ?

>> Source/WebCore/inspector/InjectedScriptWebGLModule.cpp:95
>> +void InjectedScriptWebGLModule::getTraceLog(ErrorString* errorString, const
String& traceLogId, RefPtr<TypeBuilder::WebGL::TraceLog>* traceLog)
> 
> The parameter type should use PassRefPtr instead of RefPtr. 
[readability/pass_ptr] [5]

::traceLog (according to the WebKit guidelines). We only use get prefixes in
the protocol.

> Source/WebCore/inspector/InjectedScriptWebGLModule.cpp:97
> +    ScriptFunctionCall function(injectedScriptObject(), "getTraceLog");

traceLog

> Source/WebCore/inspector/Inspector.json:3160
> +		       { "name": "traceLogId", "$ref": "TraceLogId" }

Is there a "logCaptured" event? I wonder if you should return traceLogId there
instead.

> Source/WebCore/inspector/Inspector.json:3164
> +		   "name": "getTraceLog",

traceLog

> Source/WebCore/inspector/InspectorWebGLAgent.cpp:103
> +    InjectedScript injectedScript =
m_injectedScriptManager->injectedScriptForObjectId(traceLogId);

It sounds like N-1 lines from here could be extracted and reused below.


More information about the webkit-reviews mailing list