[webkit-reviews] review denied: [Bug 93609] Rename functions in the ARM port of DFG-JIT for better code readability. : [Attachment 157738] Final patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Aug 14 02:28:07 PDT 2012


Zoltan Herczeg <zherczeg at webkit.org> has denied Gabor Ballabas
<gaborb at inf.u-szeged.hu>'s request for review:
Bug 93609: Rename functions in the ARM port of DFG-JIT for better code
readability.
https://bugs.webkit.org/show_bug.cgi?id=93609

Attachment 157738: Final patch
https://bugs.webkit.org/attachment.cgi?id=157738&action=review

------- Additional Comments from Zoltan Herczeg <zherczeg at webkit.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=157738&action=review


> Source/JavaScriptCore/assembler/ARMAssembler.h:470
> -	   void vsqrt_f64_r(int dd, int dm, Condition cc = AL)
> +	   void vsqrtFloat64(int dd, int dm, Condition cc = AL)

Do not rename this, only remove the _r. There are other similar instances,
probavbly a followup patch.

> Source/JavaScriptCore/assembler/ARMAssembler.h:475
> -	   void vabs_f64_r(int dd, int dm, Condition cc = AL)
> +	   void vabsFloat64(int dd, int dm, Condition cc = AL)

Ditto.

> Source/JavaScriptCore/assembler/ARMAssembler.h:480
> -	   void vneg_f64_r(int dd, int dm, Condition cc = AL)
> +	   void vnegFloat64(int dd, int dm, Condition cc = AL)

Ditto.


More information about the webkit-reviews mailing list