[webkit-reviews] review granted: [Bug 93834] [V8] Move hintForGCIfNecessary() from V8Proxy.h to V8GCController.h : [Attachment 157975] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Aug 13 10:38:45 PDT 2012


Adam Barth <abarth at webkit.org> has granted Kentaro Hara
<haraken at chromium.org>'s request for review:
Bug 93834: [V8] Move hintForGCIfNecessary() from V8Proxy.h to V8GCController.h
https://bugs.webkit.org/show_bug.cgi?id=93834

Attachment 157975: Patch
https://bugs.webkit.org/attachment.cgi?id=157975&action=review

------- Additional Comments from Adam Barth <abarth at webkit.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=157975&action=review


> Source/WebCore/bindings/v8/V8GCController.cpp:525
> +    if (data->shouldCollectGarbageSoon()) {

Prefer early return.

> Source/WebCore/bindings/v8/V8GCController.cpp:526
> +	   const int longIdlePauseInMs = 1000;

longIdlePauseInMs -> longIdlePauseInMS

> Source/WebCore/bindings/v8/V8GCController.h:79
> +	   static void hintForGCIfNecessary();

Can we think of a better name for this function?  Perhaps
collectGarbageIfNecessary?


More information about the webkit-reviews mailing list