[webkit-reviews] review granted: [Bug 92965] Optimize ChildNode{Insertion, Removal}Notifier::notify() by lazily taking a snapshot of child nodes : [Attachment 156248] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Aug 7 17:01:20 PDT 2012


Adam Barth <abarth at webkit.org> has granted Kentaro Hara
<haraken at chromium.org>'s request for review:
Bug 92965: Optimize ChildNode{Insertion,Removal}Notifier::notify() by lazily
taking a snapshot of child nodes
https://bugs.webkit.org/show_bug.cgi?id=92965

Attachment 156248: Patch
https://bugs.webkit.org/attachment.cgi?id=156248&action=review

------- Additional Comments from Adam Barth <abarth at webkit.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=156248&action=review


> Source/WebCore/dom/ContainerNode.h:308
> +    ChildNodesLazySnapshot(Node* parentNode)

explicit

> Source/WebCore/dom/ContainerNode.h:325
> +	   if (LIKELY(!m_childNodes.get())) {

Can we call hasSnapshot() here?  That would be slightly more readable.


More information about the webkit-reviews mailing list