[webkit-reviews] review denied: [Bug 90637] [Qt] Add support for the Gamepad API : [Attachment 156371] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Aug 3 07:54:06 PDT 2012


Noam Rosenthal <noam.rosenthal at nokia.com> has denied Marcelo Lira
<marcelo.lira at openbossa.org>'s request for review:
Bug 90637: [Qt] Add support for the Gamepad API
https://bugs.webkit.org/show_bug.cgi?id=90637

Attachment 156371: Patch
https://bugs.webkit.org/attachment.cgi?id=156371&action=review

------- Additional Comments from Noam Rosenthal <noam.rosenthal at nokia.com>
View in context: https://bugs.webkit.org/attachment.cgi?id=156371&action=review


It's unclear from the filenames and some of the other naming choices that this
is linux specific.

> Source/WebCore/platform/qt/GamepadsQt.cpp:31
> +// We do not use ENABLE or USE because moc does not expand these macros.
> +#if defined(ENABLE_GAMEPAD)

So, if we pass ENABLE_GAMEPAD=0 this would still be compiled in?
I prefer something like #if (ENABLE(GAMEPAD) || (MOC && ...))  or something
like that.

> Source/WebCore/platform/qt/GamepadsQt.cpp:50
> +class GamepadDeviceQt : public QObject, public GamepadDeviceLinux {

Maybe GamepadDeviceLinuxQt?

> Source/WebCore/platform/qt/GamepadsQt.cpp:80
> +    delete m_notifier;

QSocketNotifier is a QObject, why not just make it a child of GamepadDeviceQt?

> Source/WebCore/platform/qt/GamepadsQt.cpp:201
> +	   if (m_slots[i].get() && m_slots[i]->connected()) {

you don't need .get()


More information about the webkit-reviews mailing list