[webkit-reviews] review denied: [Bug 93097] [JSC] Remove custom JSBindings for constructArrayBufferView() : [Attachment 156342] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Aug 3 06:21:00 PDT 2012


Kentaro Hara <haraken at chromium.org> has denied Vineet Chaudhary (vineetc)
<rgf748 at motorola.com>'s request for review:
Bug 93097: [JSC] Remove custom JSBindings for constructArrayBufferView()
https://bugs.webkit.org/show_bug.cgi?id=93097

Attachment 156342: Patch
https://bugs.webkit.org/attachment.cgi?id=156342&action=review

------- Additional Comments from Kentaro Hara <haraken at chromium.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=156342&action=review


> Source/WebCore/ChangeLog:3
> +	   [JSDOMBinsding] Remove custom JSBindings for
constructArrayBufferView()

Typo: [JSDOMBinding]

Nit: We normally use a [port name]. So [JSC] would be better.

> Source/WebCore/bindings/scripts/CodeGeneratorJS.pm:338
> +    return "signed char" if $type eq "Int8Array";
> +    return "unsigned char" if $type eq "Uint8Array" or $type eq
"Uint8ClampedArray";
> +    return "short" if $type eq "Int16Array";
> +    return "unsigned short" if $type eq "Uint16Array";
> +    return "int" if $type eq "Int32Array";
> +    return "unsigned int" if $type eq "Uint32Array";
> +    return "float" if $type eq "Float32Array";
> +    return "double" if $type eq "Float64Array";

Instead of writing these sad lines, shall we introduce a [TypedArray] IDL
attribute? By using TypedArray, we can also remove sad lines in
IsTypedArrayType() and GenerateHeader(). I think that it is worth introducing a
new IDL attribute. (We want to remove hard-coding from CodeGenerators.)

> Source/WebCore/bindings/scripts/CodeGeneratorJS.pm:3820
> +	       push(@$outputArray, "	   return
JSValue::encode(JSValue());\n");

Nit: One more space before 'return'.


More information about the webkit-reviews mailing list