[webkit-reviews] review denied: [Bug 84359] datalist: Form control in a <datalist> should be barred from constraint validation : [Attachment 138993] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Apr 26 19:03:28 PDT 2012


Kent Tamura <tkent at chromium.org> has denied Keishi Hattori
<keishi at webkit.org>'s request for review:
Bug 84359: datalist: Form control in a <datalist> should be barred from
constraint validation
https://bugs.webkit.org/show_bug.cgi?id=84359

Attachment 138993: Patch
https://bugs.webkit.org/attachment.cgi?id=138993&action=review

------- Additional Comments from Kent Tamura <tkent at chromium.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=138993&action=review


r- because of build errors.

> Source/WebCore/html/HTMLFormControlElement.cpp:53
> -    , m_fieldSetAncestorValid(false)
> +    , m_fieldSetAndDatalistAncestorValid(false)

The new name looks too verbose.  How about m_ancestorsValid?

> Source/WebCore/html/HTMLFormControlElement.cpp:104
> -void HTMLFormControlElement::updateFieldSetAndLegendAncestor() const
> +void HTMLFormControlElement::updateFieldSetAndLegendAndDataListAncestor()
const

ditto.

> LayoutTests/fast/forms/datalist/datalist-child-validation.html:17
> +<style type="text/css">
> +  :invalid {
> +    background-color: red;
> +  }
> +  
> +  :valid {
> +    background-color: green;
> +  }
> +</style>

nit: No need to indent the whole block.


More information about the webkit-reviews mailing list