[webkit-reviews] review granted: [Bug 84909] Background tabs are fuzzy until repaint when deviceScaleFactor > 1 : [Attachment 138903] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Apr 25 17:26:51 PDT 2012


Darin Adler <darin at apple.com> has granted Beth Dakin <bdakin at apple.com>'s
request for review:
Bug 84909: Background tabs are fuzzy until repaint when deviceScaleFactor > 1
https://bugs.webkit.org/show_bug.cgi?id=84909

Attachment 138903: Patch
https://bugs.webkit.org/attachment.cgi?id=138903&action=review

------- Additional Comments from Darin Adler <darin at apple.com>
View in context: https://bugs.webkit.org/attachment.cgi?id=138903&action=review


> Source/WebKit2/Platform/cg/CGUtilities.h:32
> +void paintBitmapContext(CGContextRef, CGContextRef bitmapContext, CGPoint
destination, CGRect source, float scaleFactor);

Why float instead of CGFloat?

> Source/WebKit2/UIProcess/mac/BackingStoreMac.mm:101
> +    IntSize scrolledRectSize = m_scrolledRect.size();
> +    scrolledRectSize.scale(m_deviceScaleFactor);

I think it’s a little unclear to have a local variable named scrolledRectSize
that is not the same as m_scrolledRect.size(). Maybe its should be named
scrolledRectPixelsSize or scaledSize or something like that?

> Source/WebKit2/UIProcess/mac/BackingStoreMac.mm:109
> -    CGContextTranslateCTM(context.get(), 0, m_scrolledRect.size().height());

> +    CGContextTranslateCTM(context.get(), 0, m_scrolledRect.height());

This change seems to be unneeded. I am guessing you changed this to use
scrolledRectSize and then later changed it back.


More information about the webkit-reviews mailing list