[webkit-reviews] review granted: [Bug 81084] Fix rendering of replaced elements with relative dimensions within a table cell. : [Attachment 137524] Proposed patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Apr 18 08:52:41 PDT 2012


Julien Chaffraix <jchaffraix at webkit.org> has granted arpitabahuguna at gmail.com's
request for review:
Bug 81084: Fix rendering of replaced elements with relative dimensions within a
table cell.
https://bugs.webkit.org/show_bug.cgi?id=81084

Attachment 137524: Proposed patch
https://bugs.webkit.org/attachment.cgi?id=137524&action=review

------- Additional Comments from Julien Chaffraix <jchaffraix at webkit.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=137524&action=review


> Source/WebCore/rendering/RenderReplaced.cpp:562
> +    bool hasRelativeDimensions = false;
> +
> +    if (style->height().isAuto() || style->height().isPercent() ||
style->width().isAuto() || style->width().isPercent())
> +	   hasRelativeDimensions = true;
> +
> +    return hasRelativeDimensions;

This could be simplified a lot:

return style->height().isAuto() || style->height().isPercent() ||
style->width().isAuto() || style->width().isPercent();

> LayoutTests/ChangeLog:34
> +	   * platform/wincairo/Skipped:

You can always re-organize the entries to avoid duplicated text. I find that it
has the benefit of making the ChangeLog more cleaner and more readable
(smaller).

>
LayoutTests/platform/qt/fast/replaced/table-cell-width-percent-expected.txt:44
> +FAIL getWidth('input-image-td-width-percent') should be 100px. Was 530px.

Please consider filing a follow-up bug on having a test with some failing
results.


More information about the webkit-reviews mailing list