[webkit-reviews] review granted: [Bug 82701] insertedIntoDocument and insertedIntoTree should be unitifed. : [Attachment 137479] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Apr 16 22:18:26 PDT 2012


Ryosuke Niwa <rniwa at webkit.org> has granted Hajime Morrita
<morrita at google.com>'s request for review:
Bug 82701: insertedIntoDocument and insertedIntoTree should be unitifed.
https://bugs.webkit.org/show_bug.cgi?id=82701

Attachment 137479: Patch
https://bugs.webkit.org/attachment.cgi?id=137479&action=review

------- Additional Comments from Ryosuke Niwa <rniwa at webkit.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=137479&action=review


> Source/WebCore/dom/ContainerNodeAlgorithms.h:198
> +    ASSERT(m_insertionPoint->inDocument());
> +    RefPtr<Node> protect(node);
> +    Node::InsertionNotificationRequest request =
node->insertedInto(m_insertionPoint);
> +    if (node->isContainerNode())
> +	   notifyDescendantInsertedIntoDocument(toContainerNode(node));
> +    if (request == Node::InsertionShouldCallDidNotifyDescendantInseretions)
> +	   node->didNotifyDescendantInseretions(m_insertionPoint);

Maybe some blank lines would improve the readability?

> Source/WebCore/dom/ContainerNodeAlgorithms.h:209
> +    ASSERT(!m_insertionPoint->inDocument());
> +    forbidEventDispatch();
> +    Node::InsertionNotificationRequest request =
node->insertedInto(m_insertionPoint);
> +    notifyDescendantInsertedIntoTree(node);
> +    if (request == Node::InsertionShouldCallDidNotifyDescendantInseretions)
> +	   node->didNotifyDescendantInseretions(m_insertionPoint);
> +    allowEventDispatch();

Ditto.


More information about the webkit-reviews mailing list