[webkit-reviews] review granted: [Bug 83302] IndexedDB: Refactor cursor iteration to remove duplicate code : [Attachment 136934] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Apr 12 14:35:03 PDT 2012


Ojan Vafai <ojan at chromium.org> has granted Alec Flett
<alecflett at chromium.org>'s request for review:
Bug 83302: IndexedDB: Refactor cursor iteration to remove duplicate code
https://bugs.webkit.org/show_bug.cgi?id=83302

Attachment 136934: Patch
https://bugs.webkit.org/attachment.cgi?id=136934&action=review

------- Additional Comments from Ojan Vafai <ojan at chromium.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=136934&action=review


Nice cleanup!

> Source/WebCore/Modules/indexeddb/IDBLevelDBBackingStore.cpp:1099
> +
> +	   return compareIndexKeys(m_iterator->key(), m_cursorOptions.lowKey)
>= 0;
> +    }
> +    if (m_cursorOptions.highOpen)
> +	   return compareIndexKeys(m_iterator->key(), m_cursorOptions.highKey)
< 0;
> +
> +    return compareIndexKeys(m_iterator->key(), m_cursorOptions.highKey) <=
0;

nit: typically, webkit code wouldn't have these extra line-breaks. there's no
official style here though.


More information about the webkit-reviews mailing list