[webkit-reviews] review denied: [Bug 80009] Setting '0.6' to the value of a range input makes the value 0.6000000000000001 : [Attachment 136870] Patch 1 - for Preliminary Review

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Apr 12 06:45:23 PDT 2012


Kent Tamura <tkent at chromium.org> has denied yosin at chromium.org's request for
review:
Bug 80009: Setting '0.6' to the value of a range input makes the value
0.6000000000000001
https://bugs.webkit.org/show_bug.cgi?id=80009

Attachment 136870: Patch 1 - for Preliminary Review
https://bugs.webkit.org/attachment.cgi?id=136870&action=review

------- Additional Comments from Kent Tamura <tkent at chromium.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=136870&action=review


Would you show how many bytes will the WebCore (or a browser) size increase by?


> Source/WebCore/platform/Decimal128.cpp:13
> + * 1.    Redistributions of source code must retain the above copyright
> + *	      notice, this list of conditions and the following disclaimer.
> + * 2.    Redistributions in binary form must reproduce the above copyright
> + *	      notice, this list of conditions and the following disclaimer in
the
> + *	      documentation and/or other materials provided with the
distribution.
> + *

This is not a copyright header which Google employees usually use.

> Source/WebCore/platform/Decimal128.h:50
> +    Decimal128 operator +(double) const;

I don't think we need operators for all of these types (double, int32_t,
int64_t, uint32_t, uint64_t).  Please remove unnecessary operators.

> Source/WebCore/platform/Decimal128Impl.cpp:37
> +namespace {

We don't use anonymous namespace in WebKit.

> Source/WebCore/platform/Decimal128Impl.cpp:71
> +static const int kDpdBits = 10;
> +static const int kDpdMask = (1 << kDpdBits) - 1; // = 0x3FF

We don't use k-prefixes.
We use all-capital or all-lowercase letters for acronyms.
http://www.webkit.org/coding/coding-style.html#names-basic


More information about the webkit-reviews mailing list