[webkit-reviews] review granted: [Bug 83492] IndexedDB: Attributes for a cursor "run past the end" should be undefined. : [Attachment 136538] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Apr 11 13:23:04 PDT 2012


Ojan Vafai <ojan at chromium.org> has granted Alec Flett
<alecflett at chromium.org>'s request for review:
Bug 83492: IndexedDB: Attributes for a cursor "run past the end" should be
undefined.
https://bugs.webkit.org/show_bug.cgi?id=83492

Attachment 136538: Patch
https://bugs.webkit.org/attachment.cgi?id=136538&action=review

------- Additional Comments from Ojan Vafai <ojan at chromium.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=136538&action=review


> Source/WebCore/Modules/indexeddb/IDBCursor.cpp:175
> +void IDBCursor::setGotValue()

This does more than just set m_gotValue. Maybe this should be called something
like syncToBackendValues?

> LayoutTests/storage/indexeddb/cursor-continue-validity.html:1
> +<html>

New tests should all be in standards mode unless they're explicitly testing
quirks behavior. So, this should start with:
<!DOCTYPE html>

> LayoutTests/storage/indexeddb/cursor-continue-validity.html:7
> +<script src="resources/cursor-continue-validity.js"></script>

We've been moving away from using a separate script file for tests that are not
pure JS tests (i.e. test that can be run without a browser context). Instead,
just inline cursor-continue-validity.js. It makes maintaining the tests much
easier when the whole test is contained in one file (with the test harness code
still in external files of course).

> LayoutTests/storage/indexeddb/resources/cursor-continue-validity.js:132
> +function testModifyContinueOrder() {

Here and below, opening curly brace should be on the next line.


More information about the webkit-reviews mailing list