[webkit-reviews] review denied: [Bug 83302] IndexedDB: Refactor cursor iteration to remove duplicate code : [Attachment 136042] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Apr 6 10:58:36 PDT 2012


Tony Chang <tony at chromium.org> has denied Alec Flett <alecflett at chromium.org>'s
request for review:
Bug 83302: IndexedDB: Refactor cursor iteration to remove duplicate code
https://bugs.webkit.org/show_bug.cgi?id=83302

Attachment 136042: Patch
https://bugs.webkit.org/attachment.cgi?id=136042&action=review

------- Additional Comments from Tony Chang <tony at chromium.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=136042&action=review


> Source/WebCore/Modules/indexeddb/IDBBackingStore.h:105
> +

Nit: Extra newline?

> Source/WebCore/Modules/indexeddb/IDBLevelDBBackingStore.cpp:983
> +    virtual bool continueFunction(const IDBKey*, IteratorState nextState);

Remove the argument name |nextState|.

> Source/WebCore/Modules/indexeddb/IDBLevelDBBackingStore.cpp:1048
> +	   } else
> +	       nextState = Seek;

Why do we set nextState here?  It doesn't look like we use it later on.

> Tools/Scripts/webkitpy/style/checkers/cpp.py:1565
> +	   print "parameter: ", canonical_parameter_name
> +	   print "Acronym: ", acronym
> +	   print "In text: ", canonical_text

Did you mean to include this change?


More information about the webkit-reviews mailing list