[webkit-reviews] review granted: [Bug 83233] Add CodeGenerator support for sequence<> in callbacks : [Attachment 136012] patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Apr 6 06:25:42 PDT 2012


Kentaro Hara <haraken at chromium.org> has granted Vineet Chaudhary (vineetc)
<rgf748 at motorola.com>'s request for review:
Bug 83233: Add CodeGenerator support for sequence<> in callbacks
https://bugs.webkit.org/show_bug.cgi?id=83233

Attachment 136012: patch
https://bugs.webkit.org/attachment.cgi?id=136012&action=review

------- Additional Comments from Kentaro Hara <haraken at chromium.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=136012&action=review


> Source/WebCore/bindings/js/JSMutationCallbackCustom.cpp:45
> +/*

Remove the function.

> Source/WebCore/bindings/scripts/CodeGenerator.pm:457
> +sub SendCallbackThisValue

Nit: Maybe we want more descriptive method name. IsCallbackWithArrayType()?

> Source/WebCore/bindings/scripts/CodeGenerator.pm:465
> +

Nit: remove this line.

> Source/WebCore/bindings/scripts/CodeGeneratorJS.pm:2715
> +	       push(@implContent, "@argsCheck\n") if scalar(@argsCheck) > 0;

Nit: Just 'if @argsCheck;' would work.

> Source/WebCore/bindings/scripts/CodeGeneratorV8.pm:3069
> +	       push(@implContent, "@argsCheck\n") if scalar(@argsCheck) > 0;

Ditto.

> Source/WebCore/bindings/scripts/test/JS/JSTestCallback.cpp:174
> +    bool raisedException = false;

Nit: we normally use 'ec' for the variable name.

> Source/WebCore/bindings/v8/custom/V8MutationCallbackCustom.cpp:49
> +/*

Remove the function.


More information about the webkit-reviews mailing list