[webkit-reviews] review granted: [Bug 72279] media/track/track-webvtt-tc004-magic-header.html flakily times out : [Attachment 135819] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Apr 5 08:11:30 PDT 2012


Eric Carlson <eric.carlson at apple.com> has granted Zan Dobersek
<zandobersek at gmail.com>'s request for review:
Bug 72279: media/track/track-webvtt-tc004-magic-header.html flakily times out
https://bugs.webkit.org/show_bug.cgi?id=72279

Attachment 135819: Patch
https://bugs.webkit.org/attachment.cgi?id=135819&action=review

------- Additional Comments from Eric Carlson <eric.carlson at apple.com>
View in context: https://bugs.webkit.org/attachment.cgi?id=135819&action=review


Nice fix, thanks! Marking r+ but cq- because of the extraneous fprintf().

> Source/WebCore/html/track/WebVTTParser.cpp:152
> +    if (m_identifierData.size() >= bomLength && m_identifierData[0] ==
'\xEF'
> +	   && m_identifierData[1] == '\xBB' && m_identifierData[2] == '\xBF')
> +	   position += bomLength;

Nit: I don't think breaking the "if" line helps readability as it makes it
harder to see which line is executed when the condition is true.

> Source/WebCore/html/track/WebVTTParser.cpp:154
> +    fprintf(stderr, "WebVTTParser::hasRequiredFileIdentifier\n%s\n",
line.utf8().data());

Oops, looks like you forgot to remove some debugging code.


More information about the webkit-reviews mailing list