[webkit-reviews] review denied: [Bug 68321] [EFL] Use C++ type cast instead of C style type cast : [Attachment 108967] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Sep 29 07:43:59 PDT 2011


Lucas De Marchi <demarchi at webkit.org> has denied Gyuyoung Kim
<gyuyoung.kim at samsung.com>'s request for review:
Bug 68321: [EFL] Use C++ type cast instead of C style type cast
https://bugs.webkit.org/show_bug.cgi?id=68321

Attachment 108967: Patch
https://bugs.webkit.org/attachment.cgi?id=108967&action=review

------- Additional Comments from Lucas De Marchi <demarchi at webkit.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=108967&action=review


>>> Source/WebKit/efl/ewk/ewk_view.cpp:1053
>>> +	 int available_height = available_rect.height();
>> 
>> WebCore::IntRect availableRect =
enclosingIntRect(priv->page->chrome()->client()->pageRect());
>> 
>> and you don't need available_{width,height}. Just use .width()/.height()
below.
> 
> efl port is using mixed efl-style and webkit-style for local variable. I
think we should make a rule for local variable. This is an new item for Bug
68321. Do you want to remove "_" in available_rect and device_rect in this bug
?

I don't care too much about the name now (since it can be made in another bug).
Just send another patch removing the useless available_width, available_height,
device_width and device_height variables. Then you have my informal r+.


More information about the webkit-reviews mailing list