[webkit-reviews] review requested: [Bug 61179] Web Inspector: [Chromium] Add an ability to look up and explore an object from a heap profile : [Attachment 109160] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Sep 29 07:15:47 PDT 2011


Mikhail Naganov <mnaganov at chromium.org> has asked  for review:
Bug 61179: Web Inspector: [Chromium] Add an ability to look up and explore an
object from a heap profile
https://bugs.webkit.org/show_bug.cgi?id=61179

Attachment 109160: Patch
https://bugs.webkit.org/attachment.cgi?id=109160&action=review

------- Additional Comments from Mikhail Naganov <mnaganov at chromium.org>
Might not compile on the cr-linux bot, as the new V8 version hasn't been pushed
yet.

Also, contains 3 style violations:

Source/WebCore/inspector/InspectorProfilerAgent.cpp:382:  The parameter type
should use PassRefPtr instead of RefPtr.  [readability/pass_ptr] [5]
Source/WebCore/inspector/InspectorProfilerAgent.h:94:  The parameter type
should use PassRefPtr instead of RefPtr.  [readability/pass_ptr] [5]
-- These two can't be fixed, as in Inspector RPC we pass results this way. --

Source/WebCore/bindings/v8/ScriptProfiler.cpp:92:  An else statement can be
removed when the prior "if" concludes with a return, break, continue or goto
statement.  [readability/control_flow] [4]
-- Results of 'if' branches are different types, so '?:' can't be used. --


More information about the webkit-reviews mailing list