[webkit-reviews] review denied: [Bug 68304] offsetTop/offsetLeft return the wrong values for horizontal-bt/vertical-rl writing modes : [Attachment 108888] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Sep 27 13:19:45 PDT 2011


Dave Hyatt <hyatt at apple.com> has denied Ojan Vafai <ojan at chromium.org>'s
request for review:
Bug 68304: offsetTop/offsetLeft return the wrong values for
horizontal-bt/vertical-rl writing modes
https://bugs.webkit.org/show_bug.cgi?id=68304

Attachment 108888: Patch
https://bugs.webkit.org/attachment.cgi?id=108888&action=review

------- Additional Comments from Dave Hyatt <hyatt at apple.com>
View in context: https://bugs.webkit.org/attachment.cgi?id=108888&action=review


r=me, but you can rename xFlippedForWritingMode and yFlippedForWritingMode to
left() and top(). If you want to go further we could rename
locationIncludingFlipping() to topLeftLocation() and
locationOffsetIncludingFlipping() to topLeftLocationOffset(). I'd add copious
warnings in the header too that these represent your location relative to your
container as a physical offset, and that this is rarely what you want in
layout() methods.

> Source/WebCore/rendering/RenderBox.h:53
> +    LayoutUnit yFlippedForWritingMode() const { return
locationIncludingFlipping().y(); }
> +    LayoutUnit xFlippedForWritingMode() const { return
locationIncludingFlipping().x(); }

Rename these to left() and top().


More information about the webkit-reviews mailing list