[webkit-reviews] review granted: [Bug 68421] Stop calling UpdateSystemActivity in places where we hold power assertions that achieve the same effect : [Attachment 107961] Patch v1

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Sep 19 20:46:45 PDT 2011


mitz at webkit.org has granted Mark Rowe (bdash) <mrowe at apple.com>'s request for
review:
Bug 68421: Stop calling UpdateSystemActivity in places where we hold power
assertions that achieve the same effect
https://bugs.webkit.org/show_bug.cgi?id=68421

Attachment 107961: Patch v1
https://bugs.webkit.org/attachment.cgi?id=107961&action=review

------- Additional Comments from mitz at webkit.org
View in context: https://bugs.webkit.org/attachment.cgi?id=107961&action=review


> Source/WebCore/ChangeLog:27
> +	   (-[WebVideoFullscreenController setupVideoOverlay:]): Remove the
now-unnecessary explicit use of the WebCore namespace..

..

> Source/WebCore/platform/mac/DisplaySleepDisabler.cpp:27
> +#include "DisplaySleepDisabler.h"

Missing blank line after this.

> Source/WebCore/platform/mac/DisplaySleepDisabler.cpp:42
> +    RetainPtr<CFStringRef> reasonCF(AdoptCF, CFStringCreateWithCString(0,
reason, kCFStringEncodingUTF8));

I prefer kCFAllocatorDefault

> Source/WebCore/platform/mac/DisplaySleepDisabler.cpp:44
> +#else

Does this branch need an UNUSED_PARAM(reason)?

> Source/WebCore/platform/mac/DisplaySleepDisabler.cpp:56
> +void
DisplaySleepDisabler::systemActivityTimerFired(Timer<DisplaySleepDisabler>*
timer)

No need to name the unused parameter here.


More information about the webkit-reviews mailing list