[webkit-reviews] review granted: [Bug 67728] Refactor hyphen measurement : [Attachment 106623] Proposed changes.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Sep 7 14:02:13 PDT 2011


Darin Adler <darin at apple.com> has granted nholbrook at apple.com's request for
review:
Bug 67728: Refactor hyphen measurement
https://bugs.webkit.org/show_bug.cgi?id=67728

Attachment 106623: Proposed changes.
https://bugs.webkit.org/attachment.cgi?id=106623&action=review

------- Additional Comments from Darin Adler <darin at apple.com>
View in context: https://bugs.webkit.org/attachment.cgi?id=106623&action=review


> Source/WebCore/rendering/RenderBlockLineLayout.cpp:485
> +    RenderStyle* style = renderer->style();
> +    const AtomicString& hyphenString = style->hyphenString();
> +    return font.width(RenderBlock::constructTextRun(renderer, font,
hyphenString.string(), style));

Not sure these local variables help make this more readable.


More information about the webkit-reviews mailing list