[webkit-reviews] review denied: [Bug 67537] Implement a ProgressEvent constructor for JSC : [Attachment 106597] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Sep 7 11:09:08 PDT 2011


Sam Weinig <sam at webkit.org> has denied Kentaro Hara <haraken at google.com>'s
request for review:
Bug 67537: Implement a ProgressEvent constructor for JSC
https://bugs.webkit.org/show_bug.cgi?id=67537

Attachment 106597: Patch
https://bugs.webkit.org/attachment.cgi?id=106597&action=review

------- Additional Comments from Sam Weinig <sam at webkit.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=106597&action=review


I think there should also be an object with a valueOf() function, but this
looks much better.

> Source/WebCore/bindings/js/JSDictionary.cpp:40
> +static const double D64 = 18446744073709551616.0;

This should have a more descriptive name.

> Source/WebCore/dom/ProgressEvent.h:66
> +    ProgressEvent(const AtomicString& type, const ProgressEventInit&
initializer);

initializer parameter names is not needed.


More information about the webkit-reviews mailing list