[webkit-reviews] review granted: [Bug 67438] [chromium] Move updateLayers from LayerRendererChromium to CCLayerTreeHost : [Attachment 106153] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Sep 2 11:21:55 PDT 2011

James Robinson <jamesr at chromium.org> has granted Adrienne Walker
<enne at google.com>'s request for review:
Bug 67438: [chromium] Move updateLayers from LayerRendererChromium to

Attachment 106153: Patch

------- Additional Comments from James Robinson <jamesr at chromium.org>
R=me, excellent.  The name "CCLayerTreeHostCommon.h" is a little worrying to me
because it contains a friggin' gigantic inline templatized function.  I don't
want people to include that from another header file, or really from any file
other than CCLayerTreeHost and LayerRendererChromium.  One pattern I've seen
elsewhere in the code is to suffix these sorts of headers with
"InlineMethods.h", what would you think of doing that?

Also, shouldn't the other caller be CCLayerTreeHostImpl, not LRC?

More information about the webkit-reviews mailing list