[webkit-reviews] review granted: [Bug 71107] [Qt][WK2] Move content to resize (setResizesToContentsUsingLayoutSize) from UI process to Web process : [Attachment 112847] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Oct 28 05:15:33 PDT 2011


Kenneth Rohde Christiansen <kenneth at webkit.org> has granted Zalan Bujtas
<zbujtas at gmail.com>'s request for review:
Bug 71107: [Qt][WK2] Move content to resize
(setResizesToContentsUsingLayoutSize) from UI process to Web process
https://bugs.webkit.org/show_bug.cgi?id=71107

Attachment 112847: Patch
https://bugs.webkit.org/attachment.cgi?id=112847&action=review

------- Additional Comments from Kenneth Rohde Christiansen
<kenneth at webkit.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=112847&action=review


> Source/WebKit2/UIProcess/API/qt/qtouchwebview.cpp:118
>      if (newGeometry.size() != oldGeometry.size()) {
> +	   WebPageProxy* pageProxy = toImpl(d->page.pageRef());
> +	   // Let the WebProcess know about the new viewport size, so that
> +	   // it can resize the content accordingly.
> +	   pageProxy->setViewportSize(newGeometry.size().toSize());
>	   d->updateViewportConstraints();

Maybe we should make a d->updateViewportSize(...) method?

Anyway the naming is inconsistent with the rest of the file:
WebPageProxy* wkPage = toImpl(page.pageRef());


More information about the webkit-reviews mailing list