[webkit-reviews] review granted: [Bug 70315] [Qt][WK2] Rewrite MiniBrowser in QML : [Attachment 111980] patch for review.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Oct 21 14:27:30 PDT 2011


Kenneth Rohde Christiansen <kenneth at webkit.org> has granted Zeno Albisser
<zeno.albisser at nokia.com>'s request for review:
Bug 70315: [Qt][WK2] Rewrite MiniBrowser in QML
https://bugs.webkit.org/show_bug.cgi?id=70315

Attachment 111980: patch for review.
https://bugs.webkit.org/attachment.cgi?id=111980&action=review

------- Additional Comments from Kenneth Rohde Christiansen
<kenneth at webkit.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=111980&action=review


> Source/WebKit2/ChangeLog:6
> +	   Add a first QML based implementation of MiniBrowser.

Bit weird English. Add the first QML based implementation of MiniBrowser

> Tools/ChangeLog:6
> +
> +

remove double newline

> Tools/MiniBrowser/qt/BrowserWindow.cpp:64
> +{
> +    QObject* webView =
rootObject()->property("webView").value<QDesktopWebView*>();
> +    if (!webView)
> +	   webView = rootObject()->property("webView").value<QTouchWebView*>();

> +    return webView;
> +}

I guess a comment would be good here. Why would there not always be a desktop
view?

> Tools/MiniBrowser/qt/BrowserWindow.cpp:87
> +	   QMetaObject::invokeMethod(rootObject(), "setFocusToAddressBar",
Qt::DirectConnection);

focusAddressBar?

> Tools/MiniBrowser/qt/MiniBrowserApplication.h:48
> +    WindowOptions(QObject * parent = 0)

Style

> Tools/MiniBrowser/qt/MiniBrowserApplication.h:50
> +	   , m_printLoadedUrls(false)

I would call it printUrlsLoaded.... but maybe that is just me

> Tools/MiniBrowser/qt/MiniBrowserApplication.h:56
> +    void setPrintLoadedUrls(bool p) { m_printLoadedUrls = p; }

I think something like 'enabled' would serve better than p. It is not obvious
what p means.

> Tools/MiniBrowser/qt/qml/BrowserWindow.qml:5
> +    //do not define anchors or a initialisize here! This would messup with
QSGViewSizeRootObjetToView.

// Do ...

I am not faminilar with the word initialisize, but I guess you mean 'an
initializer' . There is also missing a C in Object (QSGView....)

> Tools/MiniBrowser/qt/qml/BrowserWindow.qml:167
> +	   source: options.useTouchWebView ? "TouchView.qml" :
"DesktopView.qml"

Ah that is where it comes from.


More information about the webkit-reviews mailing list