[webkit-reviews] review denied: [Bug 70350] Make FilterEffect::apply() independent of image data management : [Attachment 111490] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Oct 19 01:40:54 PDT 2011

Zoltan Herczeg <zherczeg at webkit.org> has denied Dirk Schulze
<krit at webkit.org>'s request for review:
Bug 70350: Make FilterEffect::apply() independent of image data management

Attachment 111490: Patch

------- Additional Comments from Zoltan Herczeg <zherczeg at webkit.org>
The patch looks good, but I am thinking of the following:

View in context: https://bugs.webkit.org/attachment.cgi?id=111490&action=review

> Source/WebCore/platform/graphics/filters/FEGaussianBlur.cpp:110
> +inline void FEGaussianBlur::platformApplyGenericBlur(ByteArray*
srcPixelArray, ByteArray* tmpPixelArray, unsigned kernelSizeX, unsigned
kernelSizeY, IntSize& paintSize)

We need a better naming here, since we should append Blur to the Neon function
as well to avoid naming inconsistency.

I would prefer mention that it is a software based option and rename it to:
platformApplySoftwareRendering(...) or platformApplySoftwareRender(...) or
something similar.

And do this for all filter effects of course.

More information about the webkit-reviews mailing list