[webkit-reviews] review granted: [Bug 70139] Follow up the recent HTMLSelectElement improvements with a little bit more : [Attachment 111075] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Oct 14 16:19:01 PDT 2011


Ryosuke Niwa <rniwa at webkit.org> has granted Darin Adler <darin at apple.com>'s
request for review:
Bug 70139: Follow up the recent HTMLSelectElement improvements with a little
bit more
https://bugs.webkit.org/show_bug.cgi?id=70139

Attachment 111075: Patch
https://bugs.webkit.org/attachment.cgi?id=111075&action=review

------- Additional Comments from Ryosuke Niwa <rniwa at webkit.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=111075&action=review


The code looks much better after this patch. r=me provided assertions in
toHTMLSelectElement are fixed.

> Source/WebCore/html/HTMLSelectElement.cpp:471
>      const Vector<HTMLElement*>& items = listItems();

This local variable seems unnecessary.

> Source/WebCore/html/HTMLSelectElement.h:168
> +    mutable Vector<HTMLElement*> m_listItems;

I'm not sure making this mutable is necessarily cleaner.

> Source/WebCore/html/HTMLSelectElement.h:181
> +    mutable bool m_shouldRecalcListItems;

Ditto.

> Source/WebCore/html/HTMLSelectElement.h:200
> +    ASSERT(!node || node->isHTMLElement());

This should be isHTMLSelectElement.

> Source/WebCore/html/HTMLSelectElement.h:206
> +    ASSERT(!node || node->isHTMLElement());

Ditto.


More information about the webkit-reviews mailing list