[webkit-reviews] review granted: [Bug 70120] [Chromium] Pass MessagePortArray to SerializedScriptValue::serialize/deserialize : [Attachment 111033] Fix

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Oct 14 11:46:55 PDT 2011


David Levin <levin at chromium.org> has granted Dmitry Lomov
<dslomov at google.com>'s request for review:
Bug 70120: [Chromium] Pass MessagePortArray to
SerializedScriptValue::serialize/deserialize
https://bugs.webkit.org/show_bug.cgi?id=70120

Attachment 111033: Fix
https://bugs.webkit.org/attachment.cgi?id=111033&action=review

------- Additional Comments from David Levin <levin at chromium.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=111033&action=review


Please fix these small issues and commit away!

> Source/WebCore/bindings/v8/SerializedScriptValue.cpp:1923
> +SerializedScriptValue::SerializedScriptValue(v8::Handle<v8::Value> value,
MessagePortArray* messagePorts, bool& didThrow)

Omit the var name (since it isn't used) or else you'll get compile errors on
some platforms.

> Source/WebCore/bindings/v8/SerializedScriptValue.cpp:1968
> +v8::Handle<v8::Value> SerializedScriptValue::deserialize(MessagePortArray*
messagePorts)

Ditto.

> Source/WebCore/bindings/v8/SerializedScriptValue.h:81
> +    SerializedScriptValue(v8::Handle<v8::Value>, MessagePortArray*
messagePorts, bool& didThrow);

Omit the variable name since it adds no information.

> Source/WebCore/bindings/v8/custom/V8DOMWindowCustom.cpp:356
> +    return handlePostMessageCallback(args, false);

We prefer enums in WebKit when the value passed in is just true/false to make
the call site more readable.

> Source/WebCore/bindings/v8/custom/V8DedicatedWorkerContextCustom.cpp:57
> +	ExceptionCode ec = 0;

Indentation is off.


More information about the webkit-reviews mailing list