[webkit-reviews] review granted: [Bug 69828] Move the content of SelectElementData into HTMLSelectElement, and remove SelectElement.{cpp, h} : [Attachment 110503] Patch 2

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Oct 11 08:40:19 PDT 2011


Darin Adler <darin at apple.com> has granted Kent Tamura <tkent at chromium.org>'s
request for review:
Bug 69828: Move the content of SelectElementData into HTMLSelectElement, and
remove SelectElement.{cpp,h}
https://bugs.webkit.org/show_bug.cgi?id=69828

Attachment 110503: Patch 2
https://bugs.webkit.org/attachment.cgi?id=110503&action=review

------- Additional Comments from Darin Adler <darin at apple.com>
View in context: https://bugs.webkit.org/attachment.cgi?id=110503&action=review


> Source/WebCore/html/HTMLSelectElement.h:164
> +    bool usesMenuList() const
> +    {
> +#if ENABLE(NO_LISTBOX_RENDERING)
> +	   return true;
> +#else
> +	   return !m_multiple && m_size <= 1;
> +#endif
> +    }

It’s good to have this inline, but it’s a little long and ugly to have here in
the class definition. I’d put it separately after the class definition.

> Source/WebCore/html/HTMLSelectElement.h:178
>      Vector<Element*> m_listItems;

These should be HTMLFormControlElement*. The only reason they are Element* was
WML support.

> Source/WebCore/html/HTMLSelectElement.h:191
>      bool m_recalcListItems;

I think this should be renamed (later) m_shouldRecalcListItems or something
even better.


More information about the webkit-reviews mailing list