[webkit-reviews] review granted: [Bug 69792] [V8] CodeGeneratorV8 shouldn't hardcode the list of ActiveDOMObjects : [Attachment 110432] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Oct 10 16:41:39 PDT 2011


Nate Chapin <japhet at chromium.org> has granted Adam Barth <abarth at webkit.org>'s
request for review:
Bug 69792: [V8] CodeGeneratorV8 shouldn't hardcode the list of ActiveDOMObjects
https://bugs.webkit.org/show_bug.cgi?id=69792

Attachment 110432: Patch
https://bugs.webkit.org/attachment.cgi?id=110432&action=review

------- Additional Comments from Nate Chapin <japhet at chromium.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=110432&action=review


:-D

> Source/WebCore/bindings/scripts/CodeGeneratorV8.pm:438
> +ALWAYS_INLINE v8::Handle<v8::Object>
${className}::existingWrapper(${nativeType}* impl)
> +{
> +END
> +    my $getWrapper = IsNodeSubType($dataNode) ?
"V8DOMWrapper::getWrapper(impl)" : "${domMapFunction}.get(impl)";
> +    push(@headerContent, <<END);
> +    return ${getWrapper};
> +}

I assume this is just for readability?


More information about the webkit-reviews mailing list