[webkit-reviews] review granted: [Bug 69509] [GTK] Add estimated-progress property to WebKitWebLoaderClient : [Attachment 109939] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Oct 6 08:39:27 PDT 2011


Martin Robinson <mrobinson at webkit.org> has granted Carlos Garcia Campos
<cgarcia at igalia.com>'s request for review:
Bug 69509: [GTK] Add estimated-progress property to WebKitWebLoaderClient
https://bugs.webkit.org/show_bug.cgi?id=69509

Attachment 109939: Patch
https://bugs.webkit.org/attachment.cgi?id=109939&action=review

------- Additional Comments from Martin Robinson <mrobinson at webkit.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=109939&action=review


I think estimated-progress is fine. :)

> Source/WebKit2/UIProcess/API/gtk/WebKitWebLoaderClient.cpp:259
> +	* An estimate of the percent complete for a document load. This

complete->completion Maybe you should say "for the current loading operation."
It includes subresources and subdocuments too, so maybe you shouldn't mention
the document. Might want to explicitly say that it includes all subresources,
actually.

> Source/WebKit2/UIProcess/API/gtk/WebKitWebLoaderClient.cpp:264
> +	* to be received for a document, including all it's possible
subresources.

it's -> its

> Source/WebKit2/UIProcess/API/gtk/WebKitWebLoaderClient.cpp:270
> +							   "An estimate of the
percent complete for a document load",

complete -> completion

> Source/WebKit2/UIProcess/API/gtk/tests/testloading.c:80
> +    fixture->progress = 0.;

No need for the extra period here.


More information about the webkit-reviews mailing list