[webkit-reviews] review denied: [Bug 69015] Web Inspector: Add support for search in script content. : [Attachment 109659] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Oct 4 11:41:30 PDT 2011

Ryosuke Niwa <rniwa at webkit.org> has denied Vsevolod Vlasov
<vsevik at chromium.org>'s request for review:
Bug 69015: Web Inspector: Add support for search in script content.

Attachment 109659: Patch

------- Additional Comments from Ryosuke Niwa <rniwa at webkit.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=109659&action=review

>> Source/WebCore/inspector/InspectorDebuggerAgent.cpp:324
>> +void InspectorDebuggerAgent::searchInContent(ErrorString* error, const
String& scriptId, const String& query, RefPtr<InspectorArray>* results)
> The parameter type should use PassRefPtr instead of RefPtr. 
[readability/pass_ptr] [5]

We don't use pointers to get values out of a function. Please use a reference
instead. r- because of this.

More information about the webkit-reviews mailing list