[webkit-reviews] review denied: [Bug 73025] IndexedDB: Cursor pre-fetching : [Attachment 117237] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Nov 30 12:15:14 PST 2011


Tony Chang <tony at chromium.org> has denied Hans Wennborg <hans at chromium.org>'s
request for review:
Bug 73025: IndexedDB: Cursor pre-fetching
https://bugs.webkit.org/show_bug.cgi?id=73025

Attachment 117237: Patch
https://bugs.webkit.org/attachment.cgi?id=117237&action=review

------- Additional Comments from Tony Chang <tony at chromium.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=117237&action=review


Just some minor style nits.  @jsbell: Does this look good to you?

> Source/WebCore/storage/IDBCallbacks.h:59
> +    virtual void onSuccessWithPrefetch(Vector<RefPtr<IDBKey> > keys,
Vector<RefPtr<IDBKey> > primaryKeys, Vector<RefPtr<SerializedScriptValue> >
values) = 0;

Can these be const references to avoid copying the vectors?

> Source/WebCore/storage/IDBCursorBackendImpl.h:73
> +    static void prefetchContinueInternal(ScriptExecutionContext*,
PassRefPtr<IDBCursorBackendImpl>, int, PassRefPtr<IDBCallbacks>);

Nit: I would name the int since it's not obvious from the name what it is for.

> Source/WebCore/storage/IDBKey.h:83
> +	   idbKey->m_sizeEstimate = 100;

Maybe add a comment of why 100 here?


More information about the webkit-reviews mailing list