[webkit-reviews] review denied: [Bug 73258] WebSQLDatabase could use some better error reporting. : [Attachment 116830] reportError

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Nov 28 23:05:02 PST 2011


David Levin <levin at chromium.org> has denied Michael Nordman
<michaeln at google.com>'s request for review:
Bug 73258: WebSQLDatabase could use some better error reporting.
https://bugs.webkit.org/show_bug.cgi?id=73258

Attachment 116830: reportError
https://bugs.webkit.org/attachment.cgi?id=116830&action=review

------- Additional Comments from David Levin <levin at chromium.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=116830&action=review


Just a few minor nits. Should be very quick to fix up.

> Source/WebCore/storage/AbstractDatabase.cpp:189
> +				      const String& displayName, unsigned long
estimatedSize, bool isSyncDatabase)

Since the new parameter isSyncDatabase is passed as true/false at the calling
site (as opposed to a variable name that would be more readable), it is the
current style to make this an enum.

> Source/WebCore/storage/AbstractDatabase.cpp:605
> +{ }

Ideally put the } on a new line or the { } at the end of the line is another
typical style.

> Source/WebCore/storage/ChangeVersionWrapper.cpp:57
> +					 sqliteError, 
database->sqliteDatabase().lastErrorMsg());

extra space after ,

> Source/WebCore/storage/SQLTransaction.cpp:485
> +	       m_database->reportCommitTransactionResult(3,
SQLError::UNKNOWN_ERR, 0); // ???

why the // ??? ?


More information about the webkit-reviews mailing list