[webkit-reviews] review granted: [Bug 73089] [Qt][WK2] Move event handling out of QtWebPageProxy : [Attachment 116530] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Nov 25 02:38:59 PST 2011


Kenneth Rohde Christiansen <kenneth at webkit.org> has granted Jesus
Sanchez-Palencia <jesus at webkit.org>'s request for review:
Bug 73089: [Qt][WK2] Move event handling out of QtWebPageProxy
https://bugs.webkit.org/show_bug.cgi?id=73089

Attachment 116530: Patch
https://bugs.webkit.org/attachment.cgi?id=116530&action=review

------- Additional Comments from Kenneth Rohde Christiansen
<kenneth at webkit.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=116530&action=review


I like this

> Source/WebKit2/UIProcess/API/qt/qquickwebview.cpp:57
> +    eventHandler.reset(new QtWebPageEventHandler(pageProxy->pageRef()));

Why does this needs to be reset? comment?

> Source/WebKit2/UIProcess/qt/QtTapGestureRecognizer.cpp:37
> +    , m_qtEventHandler(eventHandler)

why the m_qt*?

> Source/WebKit2/UIProcess/qt/QtTapGestureRecognizer.h:52
> -    QtTapGestureRecognizer(QtViewportInteractionEngine*, QtWebPageProxy*);
> +    QtTapGestureRecognizer(QtViewportInteractionEngine*,
QtWebPageEventHandler*);

Makes so much more sense :-)

> Source/WebKit2/UIProcess/qt/QtWebPageEventHandler.cpp:144
> +    // For some reason mouse press results in mouse hover (which is
> +    // converted to mouse move for WebKit). We ignore these hover
> +    // events by comparing lastPos with newPos.
> +    // NOTE: lastPos from the event always comes empty, so we work
> +    // around that here.

I wouldnt compress this comment so much,,, hard to read

> Source/WebKit2/UIProcess/qt/QtWebPageEventHandler.cpp:157
> +    if (m_tripleClickTimer.isActive() && (ev->pos() -
m_tripleClick).manhattanLength() < qApp->styleHints()->startDragDistance()) {

Im not sure qApp is correct here, simon?

> Source/WebKit2/UIProcess/qt/QtWebPageEventHandler.cpp:158
> +	   m_webPageProxy->handleMouseEvent(NativeWebMouseEvent(ev,
/*eventClickCount=*/3));

/* eventClickCount */ 3 

would be more readable


More information about the webkit-reviews mailing list