[webkit-reviews] review denied: [Bug 72839] [Chromium] Add WebHitTestInfo for Android : [Attachment 116011] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sun Nov 20 20:45:39 PST 2011


Darin Fisher (:fishd, Google) <fishd at chromium.org> has denied Adam Barth
<abarth at webkit.org>'s request for review:
Bug 72839: [Chromium] Add WebHitTestInfo for Android
https://bugs.webkit.org/show_bug.cgi?id=72839

Attachment 116011: Patch
https://bugs.webkit.org/attachment.cgi?id=116011&action=review

------- Additional Comments from Darin Fisher (:fishd, Google)
<fishd at chromium.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=116011&action=review


> Source/WebKit/chromium/public/WebHitTestInfo.h:45
> +    WebHitTestInfo();

constructors would need to be exported too... however, we usually just
implement
these inline.  The copy constructor usually is implemented in terms of an
assign method.

> Source/WebKit/chromium/public/WebHitTestInfo.h:61
> +    WEBKIT_EXPORT bool isContentEditable() const;

is this true when the hit was a <input type="text"> element?  "content
editable" means something more specific, no?  maybe this should just be named
isEditable?

> Source/WebKit/chromium/public/WebWidget.h:159
> +    virtual WebHitTestInfo hitTestInfoForWindowPos(const WebPoint&) { return
WebHitTestInfo(); }

nit: it is normal for WebWidget to deal in window coordinates.	also, WebWidget
doesn't really have a concept of content coordinates.  maybe since the hit test
result seems very document-specific, this hit test method should exist on
WebView instead?  I think this method could just be named hitTest (since
viewport coordinates are the default coordinate space).

> Source/WebKit/chromium/src/WebViewImpl.cpp:2674
> +    return hitTestResultForWindowPos(pos);

is it safe to call hitTestResultForWindowPos if layout is out-of-date?	(i
haven't confirmed if it forces layout.)


More information about the webkit-reviews mailing list