[webkit-reviews] review canceled: [Bug 65769] New renderer for SVGRectElement : [Attachment 112678] Proposed patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Nov 18 07:25:53 PST 2011


Renata Hodovan <reni at webkit.org> has canceled Renata Hodovan
<reni at webkit.org>'s request for review:
Bug 65769: New renderer for SVGRectElement
https://bugs.webkit.org/show_bug.cgi?id=65769

Attachment 112678: Proposed patch
https://bugs.webkit.org/attachment.cgi?id=112678&action=review

------- Additional Comments from Renata Hodovan <reni at webkit.org>
This new version contains the following:
 * Adapting it to the relevant modifications what are commited from the
previous version (e.g.: the removed toPathData(), etc.)
 * Few refactoring, mainly related to the calculating of the boundingboxes.
 * Merge inflateWithMarkerBounds() and stroke plumping code snippet into one
common inflateWithStrokeandMarkerBounds() function.
 * The previous version contained a solution for avoiding the shadow painting
problem on mac. Since Chromium uses the same painting method like mac we needed
to extend the #if PLATFORM(MAC) condition with (PLATFORM(CHROMIUM) &&
OS(MAC_OS_X)).
 * Pixel expecteds of the following tests are updated:
       * svg/W3C-SVG-1.1/coords-trans-01-b.svg
       * svg/custom/percentage-rect.svg
   Their results were one pixel slimmer than it was expected. The problematic
rects had transformations and its sizes were defined in percentages.
   I dumped a mass of datas and got the following: all the bounding boxes and
transformations paramters remained the same like in the original
RenderSVGPath's implementation. Additionally, I tried to use fillPath() in my
patch instead of fillRect() and the tests were succeeded again. That's in
RenderSVGRect::fillShape() :

       context->fillRect(m_boundingBox);

       was changed to:

       Path tmp;
       tmp.addRect(m_boundingBox);
       context->fillPath(tmp);

    I suppose it means that just the difference of precision of the two methods
was resposible for the fail. Any other idea?


More information about the webkit-reviews mailing list