[webkit-reviews] review denied: [Bug 71854] Access key should work on all elements : [Attachment 115586] fixing faling test

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Nov 17 23:16:13 PST 2011


Ryosuke Niwa <rniwa at webkit.org> has denied Vineet Chaudhary (vineetc)
<rgf748 at motorola.com>'s request for review:
Bug 71854: Access key should work on all elements
https://bugs.webkit.org/show_bug.cgi?id=71854

Attachment 115586: fixing faling test
https://bugs.webkit.org/attachment.cgi?id=115586&action=review

------- Additional Comments from Ryosuke Niwa <rniwa at webkit.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=115586&action=review


> Source/WebCore/html/HTMLElement.cpp:777
>  void HTMLElement::accessKeyAction(bool sendToAnyElement)

Per IRC discussion, we should rename this argument to sendMouseEvents or
sendMouseDownAndMouseUp. r- because we definitely don't want to land the patch
as is.

> LayoutTests/fast/forms/access-key-for-all-elements.html:31
> +    testElement.onclick = function () { debug(testElement.tagName + '
element was clicked.') };
> +    testElement.onfocus = function () { debug(testElement.tagName + '
element was focused.') };

Instead of using debug here. You can do something like:

var clicked = false;
testElement.onclick = function () { clicked = true; }
var focused = false;
testElement.onclick = function () { focused = true; }

shouldBe("pressKey(testElement.accessKey);[clicked, focused]", expected_value);


where expected_value is specific to each tagName.


More information about the webkit-reviews mailing list