[webkit-reviews] review granted: [Bug 72044] Add a simple content layer to TiledCoreAnimationDrawingArea : [Attachment 114544] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Nov 10 12:42:27 PST 2011


Darin Adler <darin at apple.com> has granted Anders Carlsson
<andersca at apple.com>'s request for review:
Bug 72044: Add a simple content layer to TiledCoreAnimationDrawingArea
https://bugs.webkit.org/show_bug.cgi?id=72044

Attachment 114544: Patch
https://bugs.webkit.org/attachment.cgi?id=114544&action=review

------- Additional Comments from Darin Adler <darin at apple.com>
View in context: https://bugs.webkit.org/attachment.cgi?id=114544&action=review


> Source/WebKit2/WebProcess/WebPage/mac/TiledCoreAnimationDrawingArea.mm:47
> +- (id)_initWithWebPage:(WebKit::WebPage *)webPage;

Why the underscore? If the entire class is private, then I’d expect that to be
expressed in the class name. Is there some sense in which this is private?

> Source/WebKit2/WebProcess/WebPage/mac/TiledCoreAnimationDrawingArea.mm:86
> -    m_rootLayer.get().frame = (CGRect)m_webPage->bounds();
> +    m_rootLayer.get().frame = static_cast<CGRect>(m_webPage->bounds());

Is there a way we can trigger this conversion without a cast? Maybe use a local
variable? Back when I worked on Boost I had proposed an implicit_cast, which
would do only conversions that could be done with an assignment and no cast at
all. A static_cast seems too powerful to me.


More information about the webkit-reviews mailing list