[webkit-reviews] review denied: [Bug 49257] [Chromium] DRT does not have LayoutTestController.pageSizeAndMarginsInPixels : [Attachment 114370] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Nov 9 15:29:07 PST 2011


Tony Chang <tony at chromium.org> has denied Stephen Chenney
<schenney at chromium.org>'s request for review:
Bug 49257: [Chromium] DRT does not have
LayoutTestController.pageSizeAndMarginsInPixels
https://bugs.webkit.org/show_bug.cgi?id=49257

Attachment 114370: Patch
https://bugs.webkit.org/attachment.cgi?id=114370&action=review

------- Additional Comments from Tony Chang <tony at chromium.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=114370&action=review


> Source/WebKit/chromium/public/WebFrame.h:475
> +    virtual void getPageSizeAndMarginsInPixels(int pageIndex,

Is it safe to rename this?  I see it called from chrome:
http://codesearch.google.com/codesearch#OAMlx_jo-ck/src/chrome/renderer/print_w
eb_view_helper.cc&exact_package=chromium&ct=rc&cd=21&q=pageSizeAndMarginsInPixe
ls&sq=

Also, webkit style is to not use the 'get' prefix.

> Source/WebKit/chromium/public/WebFrame.h:485
> +    virtual WebString getPageProperty(const WebString& propertyName,
> +					 int pageIndex) = 0;

No 'get'.  For example, LayoutTestController{Mac,Win,Qt,etc}.cpp all use
pageProperty().


More information about the webkit-reviews mailing list