[webkit-reviews] review granted: [Bug 71734] The Full Keyboard Access preference should be read in the UI process : [Attachment 113931] proposed patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Nov 7 14:41:38 PST 2011


Darin Adler <darin at apple.com> has granted Alexey Proskuryakov <ap at webkit.org>'s
request for review:
Bug 71734: The Full Keyboard Access preference should be read in the UI process
https://bugs.webkit.org/show_bug.cgi?id=71734

Attachment 113931: proposed patch
https://bugs.webkit.org/attachment.cgi?id=113931&action=review

------- Additional Comments from Darin Adler <darin at apple.com>
View in context: https://bugs.webkit.org/attachment.cgi?id=113931&action=review


> Source/WebKit2/WebProcess/WebProcess.h:99
> +    bool fullKeyboardAccessEnabled() { return m_fullKeyboardAccessEnabled; }


Maybe make this const?

> Source/WebKit2/WebProcess/WebProcess.h:146
> +    void fullKeyboardAccessModeChanged(bool mode);

The word “mode” is not a great name for this argument. Maybe
“fullKeyboardAcessEabled”?

I’m not sure that xxxChanged is a great name for something that just sets the
mode. I think setFullKeyboardAccessEnabled is a better name.


More information about the webkit-reviews mailing list