[webkit-reviews] review denied: [Bug 61493] Switch positionOverflowControls to IntPoint : [Attachment 94908] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu May 26 06:28:34 PDT 2011


Eric Seidel <eric at webkit.org> has denied Levi Weintraub <leviw at chromium.org>'s
request for review:
Bug 61493: Switch positionOverflowControls to IntPoint
https://bugs.webkit.org/show_bug.cgi?id=61493

Attachment 94908: Patch
https://bugs.webkit.org/attachment.cgi?id=94908&action=review

------- Additional Comments from Eric Seidel <eric at webkit.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=94908&action=review

> Source/WebCore/rendering/RenderLayer.cpp:2030
> +    IntRect absBounds(borderBox.x() + offsetFromLayer.x(), borderBox.y() +
offsetFromLayer.y(), borderBox.width(), borderBox.height());

And here... :)	Definitely a size.   (I've yet to see the true appeal of the
size vs. point dichotomy.  Mostly it's just a pain to work with.)

> Source/WebCore/rendering/RenderLayer.cpp:2046
> +	       layer->setPosition(IntPoint(m_hBar->frameRect().x() -
offsetFromLayer.y(), m_hBar->frameRect().y() - offsetFromLayer.y()));

Seems this wants to be a size, cause then you would just do point math there.

> Source/WebCore/rendering/RenderLayer.cpp:2053
> +	       layer->setPosition(IntPoint(m_vBar->frameRect().x() -
offsetFromLayer.x(), m_vBar->frameRect().y() - offsetFromLayer.y()));

And here.


More information about the webkit-reviews mailing list