[webkit-reviews] review denied: [Bug 61155] [fileapi] Add a File::createWithName method to avoid obfuscated filename leakage from FileEntry.file() method : [Attachment 94143] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu May 19 17:06:24 PDT 2011


Jian Li <jianli at chromium.org> has denied Adam Klein <adamk at chromium.org>'s
request for review:
Bug 61155: [fileapi] Add a File::createWithName method to avoid obfuscated
filename leakage from FileEntry.file() method
https://bugs.webkit.org/show_bug.cgi?id=61155

Attachment 94143: Patch
https://bugs.webkit.org/attachment.cgi?id=94143&action=review

------- Additional Comments from Jian Li <jianli at chromium.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=94143&action=review

> Source/WebCore/ChangeLog:20
> +	   Added an optional name argument to ensure MIME type lookup uses the

I think you can move your comment "Added an ..." to be immediately following ":
" of the previous line.

> Source/WebCore/ChangeLog:24
> +	   as it now needs to mutate the created File before returning it.

Not sure I understand your comment about "out-of-lined" and "mutate".  Probably
just the first half sentence seems to be enough.

> Source/WebCore/fileapi/File.h:56
> +    static PassRefPtr<File> createWithName(const String& path, const String&
name)

Please add the comment saying that |name| is the filename that is observed by
the user, that might be different from the real filename embedded in |path|.

Or maybe even better, consider rename |name| to something like |observedName|.


More information about the webkit-reviews mailing list