[webkit-reviews] review granted: [Bug 60916] Plug-in hit testing is broken after zooming : [Attachment 93688] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon May 16 14:05:15 PDT 2011


Darin Adler <darin at apple.com> has granted Chris Marrin <cmarrin at apple.com>'s
request for review:
Bug 60916: Plug-in hit testing is broken after zooming
https://bugs.webkit.org/show_bug.cgi?id=60916

Attachment 93688: Patch
https://bugs.webkit.org/attachment.cgi?id=93688&action=review

------- Additional Comments from Darin Adler <darin at apple.com>
View in context: https://bugs.webkit.org/attachment.cgi?id=93688&action=review

r=me

> Source/WebKit2/Shared/WebMouseEvent.cpp:81
> +WebMouseEvent::WebMouseEvent(const WebMouseEvent* event, float
pageScaleFactor)

I suggest using a reference rather than a pointer for the event type.

> Source/WebKit2/Shared/WebMouseEvent.cpp:85
> +    , m_globalPosition(m_position)

I believe you can write:

    , m_globalPosition(m_position + (event->globalPosition() -
event->position()))

And then avoid the code below that calls the move function.

> Source/WebKit2/WebProcess/Plugins/PluginView.cpp:579
> +	   WebMouseEvent webMouseEvent(static_cast<const
WebMouseEvent*>(currentEvent), scaleFactor);

I think this local needs a better name. The current event is also a web mouse
event. How about eventWithScaledCoordinates?


More information about the webkit-reviews mailing list