[webkit-reviews] review granted: [Bug 60439] [Texmap][Qt] Upstream texture-mapper changes from Qt's WebKit2 branch : [Attachment 92714] Patch 8: GL backend

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sun May 8 09:15:32 PDT 2011


Kenneth Rohde Christiansen <kenneth at webkit.org> has granted Noam Rosenthal
<noam.rosenthal at nokia.com>'s request for review:
Bug 60439: [Texmap][Qt] Upstream texture-mapper changes from Qt's WebKit2
branch
https://bugs.webkit.org/show_bug.cgi?id=60439

Attachment 92714: Patch 8: GL backend
https://bugs.webkit.org/attachment.cgi?id=92714&action=review

------- Additional Comments from Kenneth Rohde Christiansen
<kenneth at webkit.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=92714&action=review

Already mostly reviewed in person with No'am at the WebKit contributors meeting


> Source/WebCore/platform/graphics/opengl/TextureMapperGL.cpp:169
> +	   GLuint findOrCreate(ImageUid image, bool& found)

I would use ImageUID imageID or similar

> Source/WebCore/platform/graphics/opengl/TextureMapperGL.cpp:346
> -"		       gl_FragColor = vec4(color.rgb * Opacity, color.a *
Opacity);    \n"
> +"		       gl_FragColor = vec4(color.rgba * Opacity);    \n"

For consistency reasons you should add more spaces before the \n

> Source/WebCore/platform/graphics/opengl/TextureMapperGL.cpp:420
> +    drawTexture(textureGL.id(), textureGL.isOpaque(),
textureGL.relativeSize(), targetRect, matrix, opacity, mask, false);

What is false here? pls make that clear /* flip */

> Source/WebCore/platform/graphics/opengl/TextureMapperGL.h:91
> +typedef uint64_t ImageUid;

I think ImageUID would be a better type


More information about the webkit-reviews mailing list