[webkit-reviews] review denied: [Bug 56375] [Qt] PageGroup::closeLocalStorage() should be called when the app quits : [Attachment 91961] Make changes listed in Comment #7.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon May 2 13:22:09 PDT 2011


Andreas Kling <kling at webkit.org> has denied Joe Wild <joseph.wild at nokia.com>'s
request for review:
Bug 56375: [Qt] PageGroup::closeLocalStorage() should be called when the app
quits
https://bugs.webkit.org/show_bug.cgi?id=56375

Attachment 91961: Make changes listed in Comment #7.
https://bugs.webkit.org/attachment.cgi?id=91961&action=review

------- Additional Comments from Andreas Kling <kling at webkit.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=91961&action=review

> Source/WebKit/qt/ChangeLog:10
> +	   Added an instance count to QWebPage.  Now when the last QWebPage

Two spaces after "QWebPage."

> Source/WebKit/qt/Api/qwebpage.cpp:166
> +    WebCore::iconDatabase().close();

This should be inside #if ENABLE(ICONDATABASE)

> Source/WebKit/qt/Api/qwebpage.cpp:167
> +    WebCore::PageGroup::closeLocalStorage();

No need for the WebCore:: prefix here (or the line above.)

> Source/WebKit/qt/Api/qwebpage.cpp:393
> +    // if destroying last WebPage instance. Release resources.

Comments should be in sentence style:
// If destroying last QWebPage instance, release resources.

> Source/WebKit/qt/Api/qwebpage_p.h:214
> +    static int instanceCount; // Used to clean up when last instance
destroyed.

Unnecessary comment.


More information about the webkit-reviews mailing list