[webkit-reviews] review denied: [Bug 59190] Support for alignment for the Sun/Oracle Studio compilers : [Attachment 91170] Updated patch to fix the check-webkit-style error.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sun May 1 14:50:31 PDT 2011


Eric Seidel <eric at webkit.org> has denied Ben Taylor
<bentaylor.solx86 at gmail.com>'s request for review:
Bug 59190: Support for alignment for the Sun/Oracle Studio compilers
https://bugs.webkit.org/show_bug.cgi?id=59190

Attachment 91170: Updated patch to fix the check-webkit-style error.
https://bugs.webkit.org/attachment.cgi?id=91170&action=review

------- Additional Comments from Eric Seidel <eric at webkit.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=91170&action=review

> Source/JavaScriptCore/wtf/Vector.h:62
> +	   AlignedBufferChar *buffer()

Style.	* always pins to the type, not the name in WebKit.

> Source/JavaScriptCore/wtf/Vector.h:64
> +	       AlignedBufferChar *ptr = oversizebuffer;

style again.

> Source/JavaScriptCore/wtf/Vector.h:66
> +	       ptr += 64 - (reinterpret_cast<size_t>(ptr) & 0x3f);
> +	       return ptr;

I'm not sure why this is written out in 3 lines, seems to be a single-line
worth of code.	I don't think the locals help readability here.


More information about the webkit-reviews mailing list